Вопрос по информатике:
Сортировка. Метод выбора.
Напишите программу, которая сортирует массив и находит количество различных чисел в нем.
Пример:
Массив: 5 3 4 2 1 6 3 2 4
После сортировки: 1 2 2 3 3 4 4 5 6
Различных чисел: 6
Срочно нужно .Помогите пожалуйста ,люди ,добрые
- 11.09.2015 14:59
- Информатика
- remove_red_eye 18209
- thumb_up 16
Ответы и объяснения 1
var c, min, imin: integer;
c := 0;
var ar := readarrinteger('Массив:',readinteger());
for var i := 1 to ar.Length do
begin
min := ar[c];
imin := c;
for var j := c to ar.Length - 1 do
begin
if(ar[j] < min) then
begin
min := ar[j];
imin := j;
end;
end;
swap(ar[c], ar[imin]);
c := c + 1;
end;
write('После сортировки: ');
ar.Println;
write('Различных чисел: ',ar.Distinct.Count);
end.
- 12.09.2015 20:29
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.