Вопрос по информатике:
Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9.
- 20.02.2018 14:27
- Информатика
- remove_red_eye 15144
- thumb_up 16
Ответы и объяснения 1
N = 30;
Var
A:array[1..N] of byte;
i,Max:integer;
Begin
Max:=0;
For i:= 1 to N do
Begin
A[i]:=random(101);
if (A[i] mod 9 = 0)and(A[i] > Max) then Max:=A[i];
Write(A[i],' ');
End;
WriteLn;
if Max = 0 then WriteLn('В массиве нет элементов, кратных 9')
else WriteLn('Max = ',Max)
End.
- 21.02.2018 15:24
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.