Вопрос по информатике:
Написать программу на языке Си
Дано число х в 10 системе счисления. Перевести его в систему счисления с основанием n
- 03.02.2018 11:32
- Информатика
- remove_red_eye 14608
- thumb_up 10
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int x,n;
string S;
cout <> x;
cout <> n;
while(x / n > 0){
cout <
x = x / n;
}
if(x!=0){S = (char)(x<10?x+'0':x+'A'-10)+S;}
cout <<"x_n = "<
return 0;
}
- 04.02.2018 07:01
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.