Вопрос по информатике:
Составить программу, выводящую числа от 70 до 100, которые нечетные и делятся на 3. Найти их сумму и количество этих чисел.
- 09.01.2017 23:27
- Информатика
- remove_red_eye 6079
- thumb_up 25
Ответы и объяснения 2
//g++ 5.4.0
#include
using namespace std;
int main()
{
size_t sum = 0, count = 0;
for (size_t i = 71, c = 1; i <= 100; i += 2, ++c) {
cout << i << " ";
sum += i;
count = c;
}
cout << endl << sum << " / " << count << endl;
}
- 01.01.1970 00:00
- thumb_up 28
begin
var a:=Range(70,101).Where(i->(i mod 2=1)and(i mod 3=0)).
ToArray.Println;
writeln('s = ',a.Sum,' k = ',a.Count);
end.
Результат:
75 81 87 93 99
s = 435 k = 5
- 01.01.1970 00:00
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.