Вопрос по информатике:
1) Составьте программу вычисления произведения чисел от 1 до 10 (1*2*3*..*) 2)Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10
3)Составьте программу, которая находит сумму квадратов чисел от 1 до 10
- 23.04.2018 19:22
- Информатика
- remove_red_eye 19670
- thumb_up 28
Ответы и объяснения 1
P,i,S:integer;
Begin
P:=1;
For i:= 2 to 10 do
P:=P*i;
WriteLn('1: ',P);
P:=1;
S:=0;
For i:= 1 to 10 do
if i mod 2 = 0 then S:=S+i
else P:=P*i;
WriteLn('2:');
WriteLn('S = ',S);
WriteLn('P = ',P);
S:=0;
For i:= 1 to 10 do
S:=S+i*i;
WriteLn('3: ');
WriteLn('S = ',S);
End.
- 24.04.2018 04:19
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.