Вопрос по информатике:
Помогите!!!Нужно написать программы на Pascal + блок-схемы.
С клавиатуры последовательно вводится n-целых чисел:
1)Сколько чисел отличаются от первого на величину а?
2)Для всех чисел,кроме 1 и последнего ,определите ,сколько из них больше своих соседей?(слева и справа)
3)Вывести числа ,которые делятся на 3 ,но не делятся на 5.
- 04.05.2018 19:00
- Информатика
- remove_red_eye 8346
- thumb_up 7
Ответы и объяснения 1
n = 13;
Var
a,i,C,k:integer;
M:array[1..N] of integer;
Begin
k:=0;
Write('a = ');
ReadLn(a);
WriteLn('Введите целые числа');
For i:= 1 to n do
Read(M[i]);
For i:= 2 to n do
if M[i]-a = M[1] then k:=k+1;
WriteLn('1: k = ',k);
k:=0;
For i:= 2 to n-1 do
if (M[i-1]M[i+1]) then k:=k+1;
WriteLn('2: k = ',k);
Write('3: ');
For i:= 1 to n do
if (M[i] mod 3 = 0)and(M[i] mod 5 0) then Write(M[i],' ')
End.
- 05.05.2018 08:16
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.