Вопрос по информатике:
Задание 1. Заполнение массива от a до b
Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран.
Известно, что 1<=a
Формат ввода
Вводятся 2 целых числа 1<=a
Формат вывода
Массив из 30 элементов
Пример
Ввод
2 10
Вывод
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
в Паскале ABC ( не обновленном )
- 01.01.2017 05:19
- Информатика
- remove_red_eye 12796
- thumb_up 36
Ответы и объяснения 1
i,a,b:integer;
Begin
Read(a,b);
For i:= 1 to a-1 do
M[i]:=0;
For b:= a to b do
M[b]:=2;
For i:= b+1 to 30 do
M[i]:=0;
For i:= 1 to 30 do
Write(M[i],' ')
End.
- 02.01.2017 11:51
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.