Вопрос по информатике:
составьте программу ввода с клавиатуры элементов массива а [1..10] и вывода на экран элементов, значения которых являются квадратами целых чисел
- 02.07.2017 20:16
- Информатика
- remove_red_eye 4633
- thumb_up 73
Ответы и объяснения 1
var
a:array [1..10] of longint;
i:integer;
x:real;
begin
for i:=1 to 10 do readln(a[i]);
writeln('================================================');
for i:=1 to 10 do begin
x:=sqrt(a[i]);
if sqr(x)=a[i] then write (a[i],' ');
end;
readln;
end.
- 02.07.2017 21:19
- thumb_up 75
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.