Вопрос по информатике:
Помогите написать программу на языке Pascal, используя цикл While:
Последовательность Фибоначчи определяется так:
φ0=0, φ1=1, ..., φn=φn-1+φn-2.
По данному числу n определите n-е число Фибоначчи φn.
- 22.11.2017 21:37
- Информатика
- remove_red_eye 12159
- thumb_up 6
Ответы и объяснения 1
begin
var n:=readinteger('n =');
var f1:=0; var f2:=1; var i:=1;
while (in) do
begin
f2+=f1;
f1:=f2-f1;
inc (i);
end;
write (f2);
end.
- 23.11.2017 22:42
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.