Вопрос по информатике:
Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол-во четных положительных чисел в этой последовательности(паскаль). Срочно! Пожалуйста!!!!!!!!1
- 22.05.2018 16:50
- Информатика
- remove_red_eye 7357
- thumb_up 30
Ответы и объяснения 1
begin
writeln('Вводите числа, конец ввода - 0');
readln(a);
k:=0;
while a0 do
begin
if (a>0)and(a mod 2=0) then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа, конец ввода - 0
24
-15
47
-20
80
-34
62
0
k = 3
- 23.05.2018 20:13
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.