Вопрос по информатике:
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.
Входные данные
Входная строка содержит три целых числа, разделённых пробелами.
Выходные данные
Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.
Примеры
входные данные
1 2 1
выходные данные
2
На Паскале
- 13.09.2017 22:52
- Информатика
- remove_red_eye 4965
- thumb_up 15
Ответы и объяснения 2
begin
writeln('a, b, c:');
readln(a,b,c);
if (a=b)and(b=c)
then writeln(3)
else if (a=b)or(a=c)or(b=c) then writeln(2)
else writeln(0);
end.
Пример:
a, b, c:
1 2 1
2
- 14.09.2017 07:31
- thumb_up 23
a,b,c,k:integer;
begin
k:=1;
Read(a,b,c);
if a=b then Inc(k);
if a=c then Inc(k);
if (b=c) and (k=1) then k:=2;
Writeln(k)
end.
- 15.09.2017 13:04
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.