Вопрос по информатике:
Написать программу, которая запрашивает массив из N элементов, а затем делит все элементы массива на минимальный элемент. Протестировать программу на пассивах размерностью 5 и 10 элементов.
- 14.06.2018 10:57
- Информатика
- remove_red_eye 18196
- thumb_up 26
Ответы и объяснения 1
Var
M: array[1..32767] of real;
Min: real;
N, i: integer;
Begin
Write('N = ');ReadLn(N);
if (N <= 0) then
WriteLn('Количество элементов должно быть положительно')
else
begin
Write('Введите элементы массива в количестве ',N,' штук');
For i:= 1 to N do
Read(M[i]);
Min := M[1];
For i:= 2 to N do
if (M[i] < Min) then
Min := M[i];
WriteLn;
Write('Получившийся массив:');
For i:= 1 to N do
begin
M[i] := M[i] / Min;
Write(' ',M[i]);
end;
end
End.
- 15.06.2018 14:31
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.