Вопрос по информатике:
Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет сумму элементов массива, кратных трем и заканчивающихся на 7( программа Pascal)
- 03.08.2018 05:00
- Информатика
- remove_red_eye 13741
- thumb_up 43
Ответы и объяснения 1
i,s:integer;
begin
writeln('Введите 5 чисел:');
for i:=1 to 5 do
begin
read(a[i]);
if (a[i] mod 3 = 0)and(a[i] mod 10 = 7) then s:=s+a[i];
end;
writeln('s = ',s);
end.
Пример:
Введите 5 чисел:
125 273 117 471 207
s = 324
- 04.08.2018 07:03
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.