Вопрос по информатике:
НА с++ ПОЖАЛУЙСТА
Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N .
Входные данные
Входная строка содержит единственное целое число N .
Выходные данные
Программа должна вывести сумму натуральных чисел от 1 до введённого числа N .
Примеры
входные данные
100
выходные данные
5050
- 14.09.2017 11:53
- Информатика
- remove_red_eye 20651
- thumb_up 50
Ответы и объяснения 2
using namespace std;
int main()
{
int n,i,sum;
sum=0;
cin>>n;
for(int i=0;i<=n;i++)
sum=sum+i;
cout<
}
- 15.09.2017 01:24
- thumb_up 38
using namespace std;
int main()
{
int N,S = 0;
cin >> N;
for(int i=1; i<=N; i++)
{
S+=i;
}
cout << S << endl;
return 0;
}
- 16.09.2017 04:22
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.