Вопрос по информатике:
Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2+...+X^n и проверьте ее работу при различных значениях X и натурального N
- 24.11.2015 21:14
- Информатика
- remove_red_eye 20065
- thumb_up 31
Ответы и объяснения 1
Var
s, cur: longint;
x, n, i: integer;
begin
write('x='); read(x);
write('n='); read(n);
cur := 1; s := 0;
for i := 1 to n do begin
cur := cur * x;
s := s + cur;
end;
writeln('sum=', s)
end.
- 25.11.2015 18:28
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.