Вопрос по информатике:
В С++ ПОЖАЛУЙСТА
Напишите программу, которая вводит радиус круга и вычисляет его площадь и длину окружности.
Входные данные
Входная строка содержит одно число - радиус круга.
Выходные данные
В первой строке должно быть выведена площадь круга, а во второй строке - длина окружности. Оба значения выводятся с тремя знаками в дробной части.
Примеры
входные данные
5
выходные данные
78.540
31.416
- 08.01.2018 16:15
- Информатика
- remove_red_eye 13616
- thumb_up 39
Ответы и объяснения 1
#include
using namespace std;
int main()
{
double r, s, c;
cin >> r;
s = M_PI*r*r;
c = 2*M_PI*r;
cout.setf(ios::fixed);
cout.precision(3);
cout << s << "\n" << c << "\n";
return 0;
}
Пример:
5
78.540
31.416
- 09.01.2018 20:11
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.