Вопрос по информатике:
Помогите решить задачу, в долгу не останусь
(решил бы сам, но теории на руках нет)
Вопрос №601329 (тип: C)
Дано четырехзначное число. Написать программу, которая выводит на экран число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа
(никакие поясняющие записи в программе делать не нужно! библиотеку conio.h и команду getch() перед отправкой файла необходимо удалить!)
Пример входных и выходных данных
№ теста Входные данные Выходные данные
1 4561 5416
Ответ:
Прикрепите файл с программой в формате CPP, PAS, CS, FS или JAVA.
- 27.10.2015 11:37
- Информатика
- remove_red_eye 16803
- thumb_up 8
Ответы и объяснения 2
var a,d1,d2,d3,d4: longint;
begin
readln(a);
d1:=a div 1000;
d2:=(a mod 1000) div 100;
d3:=(a mod 100) div 10;
d4:=a mod 10 ;
writeln(d2,d1,d4,d3);
end.
- 28.10.2015 12:50
- thumb_up 42
begin
var s:=ReadInteger.ToString;
Writeln(s[2],s[1],s[4],s[3])
end.
- 29.10.2015 05:53
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.