Вопрос по информатике:
Решить двумя способами.Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. Пример: Введите число? 311 Единиц: 2
- 17.07.2018 18:31
- Информатика
- remove_red_eye 8385
- thumb_up 36
Ответы и объяснения 2
begin
var n:=readinteger('Введите число: ');
var count:=0;
repeat
if abs(n mod 10)=1 then count+=1;
n:=n div 10;
until n=0;
write ('Единиц: ', count);
end.
- 18.07.2018 10:43
- thumb_up 3
var num,k: integer;
begin
write('Введите число ');
readln(num);
k:=0;
while num0 do
begin
if abs(num mod 10)=1 then
k:=k+1;
num:=num div 10;
end;
writeln('Единиц: ',k);
end.
- 19.07.2018 22:44
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.