Вопрос по информатике:
Дана последовательность чисел, заканчивающаяся нулем (ноль - признак окончания ввода). Напишите программу, которая находит сумму чисел, кратных 6 и заканчивающихся на 4.
Пример
Ввод Вывод
1
24 78
3
54
0
- 15.03.2017 04:09
- Информатика
- remove_red_eye 4605
- thumb_up 7
Ответы и объяснения 2
begin
s:=0;
readln(i);
while i0 do
begin
if (i mod 6=0) and (i mod 10=4) then
s:=s+i;
readln(i);
end;
writeln(s);
end.
- 16.03.2017 19:27
- thumb_up 38
var a,sum: integer;
begin
readln(a);
while a0 do
begin
if (a mod 6=0) and (a mod 10=4) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
- 17.03.2017 14:40
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.