Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 8.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающееся на 8.
Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести одно число: сумму чисел, кратных 3 и оканчивающихся на 8.
- 15.12.2017 19:34
- Информатика
- remove_red_eye 13500
- thumb_up 21
Ответы и объяснения 1
Var
i, s, n, d: integer;
begin
readln(n);
for i := 1 to n do
begin
readln(d);
if (d mod 10 = 8) and (d mod 3 = 0) then
s := s + d;
end;
writeln(s);
end.
- 16.12.2017 19:26
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.