Вопрос по информатике:
Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет. Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO
- 10.01.2017 19:02
- Информатика
- remove_red_eye 16769
- thumb_up 10
Ответы и объяснения 1
const ny: array[boolean] of string[3] = ('No', 'Yes');
var n: longint; b: boolean;
begin
write('n = ');
readln(n);
n := abs(n);
b := false;
while n > 9 do
begin
b := n mod 10 = n mod 100 div 10;
if b then break;
n := n div 10
end;
writeln(ny[b]);
readln
end.
- 11.01.2017 21:41
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.