Вопрос по информатике:
Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . Входные данные Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b . Выходные данные Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.
- 22.08.2016 04:09
- Информатика
- remove_red_eye 7857
- thumb_up 51
Ответы и объяснения 1
uses crt;
var a, b: real; i: integer;
begin
randomize;
readln(a,b);
for i:= 1 to 5 do
write(' ',(Random()*(b-a)+a):0:3, ' ');
end.
- 23.08.2016 22:55
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.