Вопрос по информатике:
Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)
- 03.09.2016 04:14
- Информатика
- remove_red_eye 15247
- thumb_up 50
Ответы и объяснения 1
uses crt;
Var x, y, k:integer;
procedure delit;
begin k:=0;
writeln('Делители числа ', x, ':');
for y:=1 to x do if x mod y=0 then
begin
write( y, ' ');
k:=k+1
end;
writeln('Количество делителей числа ', x, ' равно ', k);
end;
begin clrscr;
writeln ('Введите число: ');
readln (x);
delit;
readln;
end.
- 04.09.2016 03:23
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.