Вопрос по информатике:
Задание по ИКТ!! Составить программу с пояснениями!! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их сумму. В паскале а если еще можно то блок схему)
- 13.08.2018 16:11
- Информатика
- remove_red_eye 2544
- thumb_up 36
Ответы и объяснения 1
const n=4; // число элементов
var a: array [1..n] of integer; //массив
i, sum: integer; //переменные
begin //начало
sum:=0; // сумма=0
for i:=1 to n do readln(a[i]); //вводим массив
for i:=1 to n do //цикл
if(a[i] mod 2 0) then //условие нечетности
begin
writeln(a[i]); //выводим нечетные
sum:=sum+a[i]; //считаем сумму
end;
writeln(sum); //выводим сумму
end. //конец
- 14.08.2018 09:26
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.