Вопрос по информатике:
Написать программу для подсчета количества слов максимальной длины в тексте. Текст вводится с клавиатуры. Признак окончания текста точка.
Написать на паскале с использованием циклов
Пожалуйста
- 07.03.2016 23:40
- Информатика
- remove_red_eye 14955
- thumb_up 20
Ответы и объяснения 1
uses StrUtils;
var text,buffer : String;
var tpos,lastpos,counter,biggest : Integer;
begin
tpos := 0;
text := '';
while(tpos = 0) do begin
readln(buffer);
text += buffer;
tpos := pos('.',buffer)
end;
lastpos := 1;
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
biggest := tpos-1; lastpos := tpos+1;
while(not (tpos = 0)) do begin
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
if (tpos-lastpos) > biggest then
biggest := tpos-lastpos;
lastpos := tpos+1;
end;
lastpos := 1; counter := 0;
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
while(not (tpos = 0)) do begin
if (tpos-lastpos) = biggest then
counter += 1;
lastpos := tpos + 1;
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
end;
writeln(counter);
end.
- 08.03.2016 00:09
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.