Вопрос по информатике:
Дана последовательность натуральных 3-х значных чисел, за которой следует 0. Составить программу поиска в данной последовательности элемента, сумма цифр которого равна N
Делать программу через цикл While
- 25.08.2017 22:23
- Информатика
- remove_red_eye 11996
- thumb_up 12
Ответы и объяснения 1
k: array[1..100] of integer;
a,N,i,c:integer;
begin
c:=0;
i:=1;
a:=999;
write('Введите N: ');
readln(N);
writeln('Введите a: ');
while a0 do beginr
eadln(a);
if (a>=100) and (a<=999) then begin
if ((a div 100)+((a div 10) mod 10)+(a mod 10))=N then begin
k[i]:=a;
i:=i+1;
c:=c+1;
end;
end;
end;
if c>0 then begin
writeln('Числа, сумма цифр которых равна ',N,':');
for i:= 1 to c do
writeln(k[i]);
end;
end.
- 26.08.2017 10:44
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.