Вопрос по информатике:
1.Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 2.
2.Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 2.
3.Напишите программу, которая в последовательности натуральных чисел определяет определяет сумму всех чисел, кратных 2 и оканчивающихся на 2.
Паскаль
- 28.05.2018 00:56
- Информатика
- remove_red_eye 13175
- thumb_up 7
Ответы и объяснения 1
const
n=17;
var
a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
k:=0;
for i:=1 to n do begin
a[i]:=Random(99)+1;
Write(a[i],' ');
if a[i] mod 2=0 then k:=k+1
end;
Writeln;
Writeln('k=',k)
end.
Пример
43 86 43 13 24 18 93 38 38 59 15 75 12 92 8 72 8
k=10
{ задание 2/3}
const
n=17;
var
a:array[1..n] of integer;
i,s:integer;
begin
Randomize;
s:=0;
for i:=1 to n do begin
a[i]:=Random(99)+1;
Write(a[i],' ');
if a[i] mod 10=2 then s:=s+a[i]
end;
Writeln;
Writeln('s=',s)
end.
Пример
58 39 12 24 91 57 14 44 47 61 31 10 95 54 42 98 76
s=54
- 28.05.2018 23:33
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.