Вопрос по информатике:
Дан целочисленный массив размера N, заполненный целыми числами не превышающими 104. Необходимо получить два новых массива: в первом массиве должны быть собраны только четные числа, а во втором - нечетные числа. Порядок следования элементов в новых массивах не нарушать.
Формат ввода
В первой строке входного файла записано целое число N - размер массива (1 ⩽ N ⩽ 1000). Во второй строке записано N целых чисел через пробел, не превышающих 104.
Формат вывода
- 19.03.2018 19:51
- Информатика
- remove_red_eye 15082
- thumb_up 9
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
procedure PrintArr(f:Text; a:array of integer);
begin
foreach var x in a do Write(f,x,' ');
Writeln(f)
end;
begin
var fin:=OpenRead('input.txt');
var n:=ReadlnInteger(fin);
var a:=new integer[n];
for var i:=0 to n-1 do Read(fin,a[i]);
var fout:=OpenWrite('output.txt');
fin.Close;
PrintArr(fout,a);
var b:=a.Where(x->x.IsEven).ToArray;
PrintArr(fout,b);
var c:=a.Where(x->x.IsOdd).ToArray;
PrintArr(fout,c);
fout.Close
end.
- 20.03.2018 07:49
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.