Вопрос по информатике:
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём.
Формат входных данных
Вводится целое число n (100≤n≤999)
Формат выходных данных
Требуется вывести сумму и произведение его цифр через пробел.
- 22.05.2018 20:25
- Информатика
- remove_red_eye 12870
- thumb_up 21
Ответы и объяснения 2
Uses Crt;
Var a,b,c,s,p:integer;
Begin
ClrScr;
writeln('Введи трехзначное число');
readln( a,b,c); {После ввода каждой цифры жми Enter}
s:=0; s:=a+b+c;
p:=1; p:=a*b*c;
writeln('Сумма цифр s= ',s:5, 'Произведение цифр p= ',p:7);
readkey
End.
- 24.05.2018 00:31
- thumb_up 14
using namespace std;
int main()
{
int a, a1, a2, a3, s, p;
cout <> a, cout << "\n";
a1 = a/100;
a2 = a/10 % 10;
a3 = a % 10;
s = a1+a2+a3;
p = a1*a2*a3;
cout << "s = " << s << " p = " << p << "\n";
return 0;
}
Пример:
a = 752
s = 14 p = 70
- 24.05.2018 00:43
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.