Вопрос по информатике:
Помогите пожалуйста:3
В числовую переменную последовательно вводятся целые числа, не равные нулю.
кол-во вводимых чисел n неизвестно. Найти сумму тех чисел, в которых встречаются ровно две цифры 5.(в паскале написать программу)
- 04.02.2016 03:06
- Информатика
- remove_red_eye 10737
- thumb_up 25
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var t:integer;
var k:=0;
repeat
Read(t);
if t.ToString.Where(c->c='5').Count=2 then k+=1
until t=0;
Writeln('Количество чисел с двумя пятерками равно ',k)
end.
- 05.02.2016 18:02
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.