Вопрос по информатике:
Написать ПРОГРАММУ и составить БЛОК СХЕМУ по этим задачам:
1)Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение.
2)В классе 20 учеников писали диктант по русскому.Написать программу и блок-схему подсчета кол-во оценок 2 3 4 5 получивших за диктант(писать через массив).
3)Объявлен набор в школьную баскетбольную команду.Известен рост каждого из n учеников желающих попасть в эту команду. Составьте алгоритм подсчета и блок схему количества претендентов имеющих шанс попасть в команду если рост игрока команды должен быть не менее 170 см.Запишите на языке Паскаль программу.Считайте рост претендентов случайным числом из диапазона 150-200 см, а число претендентов n=50.
- 02.08.2015 22:49
- Информатика
- remove_red_eye 9574
- thumb_up 15
Ответы и объяснения 1
a: array[1..10] of integer;
m, i,s: integer;
begin
randomize;
for i := 1 to 10 do
begin
a[i] := random(+10) + 1;
if a[i] > m then m := a[i];
end;
for i := 1 to 10 do
begin
if a[i]=m then s:=s+1;
end;
writeln(s);
end.
2)var
a: array [1..20] of 2..5; //Массив оценок учеников
i: integer;
n: array [2..5] of 2..5; //Массив счетчиков оценок
begin
for i:= 2 to 5 do //Обнуляем счетчики оценок
n[i]:= 0;
for i:= 1 to 20 do //Вводим оценки учеников и считаем их
begin
writeln('Введите оценку ', i, ' ученика');
readln(a[i]);
if a[i] = 2 then n[2]:= n[2] + 1;
if a[i] = 3 then n[3]:= n[3] + 1;
if a[i] = 4 then n[4]:= n[4] + 1;
if a[i] = 5 then n[5]:= n[5] + 1;
end;
for i:= 2 to 5 do
writeln('Количество получивших ', i, ' за диктант равно: ', n[i]); {Выводим значения счетчиков}
end.
3) Program zada4a3;Var A: array[1..50] of integer;
i,k:integer;
begin
for i:= 1 to 50 do
a[i]:= random(51)+150;
k:=0;
for i:= 1 to 50 do
if a[i]>170 then k:=k+1;
writeln(k);
end.
- 03.08.2015 09:11
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.