Вопрос по информатике:
Составьте программу, которая позволяет переставить местами cлова строки s. Строка s , состоящая из двух слов, разделённых пробелом, вводится с клавиатуры.
- 24.10.2015 16:46
- Информатика
- remove_red_eye 1174
- thumb_up 48
Ответы и объяснения 1
Program Pr1;
uses crt;
var stroka,tmp:string;
i:integer;
Begin
clrscr;
readln(stroka);
for i:=1 to length(stroka) do if stroka[i]=' ' then tmp:=copy(stroka,1,i-1);
delete(stroka,1,length(tmp)+1);
stroka:=stroka+' '+tmp;
writeln(stroka);
end.
- 25.10.2015 02:04
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.