Вопрос по информатике:
Написать программу, которая находит минимальный элемент массива. Размерность массива 4х4. Ввод элементов осуществляется с клавиатуры.
- 24.05.2018 23:55
- Информатика
- remove_red_eye 1635
- thumb_up 7
Ответы и объяснения 1
const unsigned short int S = 4;
float m[S][S];
for(size_t i = 0; i < S; i++) {
for(size_t j = 0; j < S; j++) {
cout << "m[" << i
<< "][" << j << " = ";
cin >> m[i][j];
}
}
float min = m[0][0];
for(size_t i = 0; i < S; i++) {
for(size_t j = 0; j < S; j++) {
if (m[i][j] > min) {
min = m[i][j];
}
}
}
cout << '\n' << "min: " << min;
return 0;
}
- 25.05.2018 10:23
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.