Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 5.
- 19.11.2017 17:34
- Информатика
- remove_red_eye 14639
- thumb_up 10
Ответы и объяснения 1
begin
write('n = ');
readln(n);
s:=0;
writeln('Введите ',n,' чисел:');
for i:=1 to n do
begin
read(a);
if a mod 5 = 0 then s:=s+a;
end;
writeln('s = ',s);
end.
Пример:
n = 6
Введите 6 чисел:
12 45 84 37 10 51
s = 55
- 20.11.2017 11:22
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.