Вопрос по информатике:
Составьте программу,которая заполняет массив a[1..10] случайными числами в диапазоне от 0 до 20, затем первый элемент меняет местами с максимальным
элементом.Выведите на экран исходный и полученный массивы.
- 27.03.2018 16:12
- Информатика
- remove_red_eye 14973
- thumb_up 28
Ответы и объяснения 1
g,s,i,max:integer;
begin
randomize;
writeln('первоначальный массив');
for i:=1 to 10 do
begin
s:=s+1;
mass[s]:=random(21);
if max
end;
writeln('конечный массив');
g:=mass[1];
for i:=1 to 10 do begin
if mass[i]=max then mass[i]:=g;
mass[1]:=max;
writeln(mass[i]);
end;
end.
- 28.03.2018 12:06
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.