Вопрос по информатике:
Напишите программу, которая в последовательности натуральных
чисел определяет максимальное число, кратное 5. Программа
получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, кратное 5.
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число – максимальное число, кратное 5.
Pascal
- 09.05.2015 21:12
- Информатика
- remove_red_eye 19604
- thumb_up 28
Ответы и объяснения 1
uses crt;
var a:array[1..1000] of integer;
i,max,n:integer;
begin
clrscr;
write('n<1000, n=');
read(n);
write('a[i]<30000, a[i]:');
for i:=1 to n do
begin
readln(a[i]);
max:=0;
if(a[i] mod 5=0) and (a[i]>max)
then max:=a[i];
end;
writeln('max=',max);
end.
- 10.05.2015 00:22
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.