Вопрос по информатике:
Напишите программу винипух съедает 100 грамм варенья первый день, во второй день еще 100 грамм варенья, в третий день 200 грамм варенья, в каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших днях. За сколько дней он съест К грамм варенья
- 14.12.2017 13:46
- Информатика
- remove_red_eye 17736
- thumb_up 42
Ответы и объяснения 1
var x,x1,x2,x3,y,sum:integer;
begin
writeln('введите кол-во грамм');
readln(x);if x<100 then writeln('меншье чем за час :)');
if x=100 then writeln('столько он скушает за 1 день');
if (x>100) and (x<200) then writeln('от 1 до 2 дней не включая их');
if x=200 then writeln('за два первых дня он скушает столько!)');
if x>200 then begin
x1:=100;
x2:=100;
x3:=200;
y:=2;
sum:=200;
repeat
if sum<=x then begin x2:=x1+x3; sum:=sum+x2; y:=y+1; end;
if sum<=x then begin x1:=x2+x3; y:=y+1; sum:=sum+x1; end;
if sum<=x then begin x3:=x1+x2; sum:=sum+x3; y:=y+1; end;
until (sum>=x) or (sum>=x) or (sum>=x);writeln(y);
end;
end.
- 15.12.2017 08:27
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.