Вопрос по информатике:
Напишите программу пожалуйста
Вася у папы силен в математике. Но сейчас папа в командировке, а Васе срочно нужно найти все решения такого уравнения:
x + y + x∙y = n
Поскольку Вася за долгие годы безделья разучился решать задачи без посторонней помощи, Вам предстоит по заданному целому n (0 ≤n≤ 109) найти количество таких пар целых неотрицательных чисел (x, y), чтобы выполнялось требуемое равенство. Поспешите, не то все узнают страшную правду о Васе.
- 03.09.2018 00:34
- Информатика
- remove_red_eye 10927
- thumb_up 20
Ответы и объяснения 1
begin
col:=0;
write('число - ');
readln(n);
for x:=0 to n do begin
for y:=0 to n do begin
if (x+y+x*y=n) then begin writeln(x,' ',y); col:=col+1; end;
end;
end;
write('количество - ',col);
end.
- 03.09.2018 09:20
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.