Вопрос по информатике:
Написать программу, которая заполняет одномерный массив случайными числами (-100 до 100) и выводит на экран произведение нечетных чисел
- 04.02.2018 08:39
- Информатика
- remove_red_eye 11840
- thumb_up 32
Ответы и объяснения 1
#include
using namespace std;
int main() {
int i, prod = 1;
// [5;100]
const int SIZE = rand() % 96 + 5;
int array[SIZE+1];
for(i = 0; i <= SIZE+1; i++) {
array[i] = (rand() % 201) - 100;
if (array[i] < 0) {
prod *= array[i];
}
}
cout << "произведение отрицательных чисел: " << product;
return 0;
}
- 06.02.2018 00:17
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.