Вопрос по информатике:
Заполнить массив (А) случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному.
Очень надо. Пожалуйста!!!!
- 06.07.2015 05:21
- Информатика
- remove_red_eye 756
- thumb_up 9
Ответы и объяснения 1
var a:array[1..n] of integer;
max,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
a[i]:=random(21)-10;
write(a[i],' ');
end;
writeln;
max:=a[1];
for i:=2 to n do
if a[i]>max then max:=a[i];
writeln('max = ',max);
for i:=1 to n do
if a[i]=max then write(i:3);
writeln;
end.
Пример:
Исходный массив:
-6 -9 10 -6 0 0 -8 10 -8 2
max = 10
3 8
- 07.07.2015 15:32
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.