Вопрос по информатике:
1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.
2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.
- 07.04.2015 13:41
- Информатика
- remove_red_eye 3943
- thumb_up 6
Ответы и объяснения 1
Первая (N - количество чисел в исходной последовательности):
const N = 5;
var number, i, count : integer;
begin
count := 0;
for i := 1 to N do
begin
write('Input number: ');
readln(number);
if (number mod 5 = 0) and (number mod 7 0) then
count := count + 1;
end;
writeln('Count: ',count);
readln;
end.
Вторая:
const N = 5;
var number, i, count : integer;
begin
count := 0;
for i := 1 to N do
begin
write('Input number: ');
readln(number);
if (number < 0) then
writeln('Square of ',number,' equals ',number*number);
end;
readln;
end.
- 08.04.2015 15:19
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.