Вопрос по информатике:
На каждом следующем дне рождения Винни – Пух съедает столько же пищи, сколько на двух предыдущих. На двух первых днях рождения у Пяточка и Кролика он съел по 100 грамм пищи. Написать программу, определяющую, на каком дне рождения вес съеденной пищи превысит собственный вес Винни – Пуха.
Только это надо решить в Delphi.
- 24.09.2017 17:10
- Информатика
- remove_red_eye 16928
- thumb_up 8
Ответы и объяснения 2
begin
write('Вес Винни-Пуха (г): ');
readln(m);
d1:=100; d2:=100;
dn:=100; k:=2;
while dn<=m do
begin
dn:=d1+d2;
d1:=d2;
d2:=dn;
k:=k+1;
end;
writeln('k = ',k,' dn = ',dn);
end.
Пример:
Вес Винни-Пуха (г): 900
k = 7 dn = 1300
- 26.09.2017 06:00
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.