Вопрос по информатике:
Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6.
var a,c: integer;
begin cls;
randomize;
a:=random (99999+99999+1)-99999;
writeln ( 'исходное числo: ',a);
if (a mod 10) mod 2 =0 then
writeln (' делится на 2')
else
writeln (' не делится на 2');
while a<>0 do
begin
c:= c+(a mod 10);
a:= a div 10;
end;
if c mod 3 = 0 then
writeln (' число делится на 3')
else
writeln (' число не делится на 3');
end.
признак делимости на 6 - это значит, что число делится на 2 и 3. я сделала по отдельности на 2 и 3 ( программа выше). а как это обобщить?
- 04.05.2018 20:08
- Информатика
- remove_red_eye 9691
- thumb_up 32
Ответы и объяснения 1
a, c: integer;
begin
randomize;
a := random(99999 + 99999 + 1) - 99999;
writeln('исходное числo: ', a);
while a > 0 do
begin
c := c + a mod 10;
a := a div 10;
end;
if (c mod 3 = 0) and ((a mod 10) mod 2 = 0) then
writeln(' число делится на 6')
else
writeln(' число не делится на 6');
end.
- 05.05.2018 21:37
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.