Вопрос по информатике:
1)Вычислить сумму четных и нечетных элементов(также в массиве).
2)Вычислить количество "0" в массиве.
Написать программу в Pascal.
P.S.: можно сделать одну задачу из двух.
- 09.09.2018 15:04
- Информатика
- remove_red_eye 10175
- thumb_up 41
Ответы и объяснения 1
var a: array [0..100] of integer;
var b,i,c,k:integer;
begin
randomize;
for i:=1 to 10 do
begin
a[i]:=random(10);
writeln(a[i]); // Это можно не писать, просто чтобы видеть числа в массиве, если интересно.
end;
c := 0;
b := 0;
for i:=1 to 10 do
begin
if a[i] mod 2 = 0 then
b := b + a[i]
else
c := c+ a[i];
end;
writeln('Нечетных ' , c);
writeln('Четных ' , b);
k:=0;
for i:=1 to 10 do
begin
if a[i] = 0 then
k:= k+1
end;
writeln('Нулей ' , k)
end.
- 01.01.1970 00:00
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.