Вопрос по информатике:
Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от - 20 до 20 и четные числа делит на два, а нечетные - умножает на три
Помогите, срочно!!
- 16.08.2018 02:06
- Информатика
- remove_red_eye 15487
- thumb_up 42
Ответы и объяснения 1
// Внимание! В других версиях работа не гарантируется!
begin
var a:=ArrRandom(15,-20,20); a.Println;
a:=a.Select(x->x.IsOdd?x*3:x div 2).ToArray; a.Println
end.
Пример
-1 -2 8 8 19 -12 13 -11 -7 -10 3 5 -18 4 3
-3 -1 4 4 57 -6 39 -33 -21 -5 9 15 -9 2 9
А вот так это же самое обычно делают в школах...
const
n=15;
var
a:array[1..n] of integer;
i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=Random(41)-20;
Write(a[i],' ')
end;
Writeln;
for i:=1 to n do begin
if a[i] mod 2=0 then a[i]:=a[i] div 2
else a[i]:=a[i]*3;
Write(a[i],' ')
end;
Writeln
end.
- 17.08.2018 15:23
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.