Вопрос по информатике:
СРОЧНО 25 баллов
Фермер выращивает картофель и свеклу. Фермер
продает овощи на базу N килограмм картофеля по X рублей и
столько же килограмм свеклы по Y рублей. Напишите программу,
которая выводит прибыль фермера от продажи.
Вход: N – целое положительное число от 1 до 50, X – стоимость
одного килограмма картофеля в диапазоне от 10 до 50 рублей; Y –
стоимость одного килограмма свеклы в диапазоне от 5 до 15
рублей. Первым задается число N, затем на следующей строке
число X, на следующей строке число Y.
Выход: S – прибыль продажи
- 25.06.2018 09:01
- Информатика
- remove_red_eye 11830
- thumb_up 16
Ответы и объяснения 1
JAVA
class Main{
p s v main(String[] args]{
int N, X, Y, S;
Scanner sc = new Scanner(System.in) // Ввод
int toExit = 1;
while(toExit != 0){
N = sc.nextInt();
if(1 <= N =< 50)
tiExit = 0};
int toExit = 1;
while(toExit != 0){
X = sc.nextInt();
if(10 <= N =< 50)
tiExit = 0};
int toExit = 1;
while(toExit != 0){
N = sc.nextInt();
if(5 <= N =< 15)
tiExit = 0};
S = (N * X) + (N * Y);
System.out.print("S: " + S);
}}
- 26.06.2018 19:42
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.