Вопрос по информатике:
Составить программу нахождения чисел от -100 до 100 кратных 7
pascal abc
- 03.05.2017 14:16
- Информатика
- remove_red_eye 4575
- thumb_up 29
Ответы и объяснения 1
Я взяла числа по модулю, иначе будет 0. Если тебя устраивает 0, тогда не пиши abs в условии.
var s,a: integer;
i:integer;
begin
a:=-101;
for i:=1 to 200 do begin
a:=a+1;
if a mod 7=0 then s:=s+abs(a);
end;
writeln (s);
end.
Выводит: 1470
- 04.05.2017 15:34
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.