Вопрос по информатике:
Составить программу для вычисления среднеарифметического N произвольных чисел.
Обозначения:
S-сумма всех чисел;
SR-среднеарифметическое N чисел;
A-значение I-го числа;
N-количество чисел.
- 17.09.2017 17:50
- Информатика
- remove_red_eye 18319
- thumb_up 45
Ответы и объяснения 1
PROGRAM PR17;
VAR
I,N:INTEGER;
S,SR,A:REAL:
BEGIN
WRITE(‘ Введите N’);
READLN(N);
S:=0;
FOR I:=1 TO N DO
BEGIN
WRITE(‘ Введите ‘,I,’ число’);
READLN(A);
S:=S+A:
END;
SR:=S/N;
43 WRITELN(‘Ответ: SR = ’,SR:8:3);
END.
- 18.09.2017 06:39
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.