Вопрос по информатике:
Чуваки, помогите. Не шарю совсем, надо написать программу и лучше с объяснениями.
Дано натуральное число. Верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
- 11.01.2018 00:29
- Информатика
- remove_red_eye 13997
- thumb_up 12
Ответы и объяснения 1
Требуемая программа:
var n,a: longint; b: boolean;
begin
readln(n);
readln(a);
b:=false;
while n>0 do
begin
if n mod 10 = a then b:=true;
n:=n div 10;
end;
if b
then writeln('В числе есть введенная цифра')
else writeln('В числе нет введенной цифры');
end.
Пример:
1236548
2
В числе есть введенная цифра
- 11.01.2018 18:30
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.