Вопрос по информатике:
Помогите написать программу на Паскале
1.написать функцию,подсчитывающую количество единиц в числе и с её помощью определить,в каком из двух чисел единиц больше.
- 13.09.2017 15:44
- Информатика
- remove_red_eye 5592
- thumb_up 18
Ответы и объяснения 1
Var
s, s2: string;
function one(s: string): integer;
var i, c: integer;
begin
c := 0;
for i := 1 to length(s) do
if (s[i] = '1') then c := c + 1;
result := c;
end;
begin
writeln('Введите первое число:');
readln(s);
writeln('Введите второе число:');
readln(s2);
if(one(s) > one(s2)) then write('В первом числе больше единиц')
else write('Во втором числе больше единиц');
end.
- 14.09.2017 13:14
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.